New Template – Midnight Rainforest

I’ve just completed working on a new template called Midnight Rainforest.

This template is free, open-source, following only the Creative Commons Attribution 2.5 license.

There are two versions of the site template done at this point. One is a three column and one is a two column layout. The templates are CSS based, table-less layouts and validate to XHTML 1.0 Strict. They use one image, shown in multiple places just to give examples of where you might want an image.

I have included some matching text styles to cover basics like blockquotes, code, and data tables. All the text sizing is done using the 76% concept to keep them fluid with em sizing. Here’s a screen shot of the 3-column layout:

Midnight Rainforest - 3 column

That’s about all, feel free to go to the main page for it and pick the layout you want. Remember to save the image used also.

Download selection page: Midnight Rainforest

7 thoughts

  1. Hi

    I liked the Midnight Rainforest template . But I am unable to upload the same to my blog in blogger . Can you please help me out ?

    Thanks and Regards

    Rakesh

  2. @Rakesh

    The design is created for standard HTML pages. Blogger uses special code to implement its templates. You would have to convert the design to blogger code for it to work for Blogger.

  3. Hi! I know its been years, but I still use your Midnight Rainforest template.
    However, since updating WordPress the comment pages error out with unexpected “endif”
    You can see what I mean if you visit http://www.safetinspector.com and look at the comments on any of the posts you find there

    Is there anythink simple I can do to correct this?

  4. Joe,
    Thanks for being a long-time user of that template! I’ll do my best to get your site back up and running properly. The first thing to check is whether or not the upgrade killed a plugin that you were using. That’s one of the most common causes of this sort of error. Log into your wordpress backend, and go to the plugins page. You want to check to see if any of the plugins are flagged for an upgrade needed (there will be some text like ‘there is a newer version of such and such available’). Upgrade them if available, then check one of your pages again to see if the comments work now. If that doesn’t fix the problem, the next troubleshooting step is to select all your active plugins and then use the bulk actions drop-down to deactivate them all. Check your comments section, if the error is gone you know the problem is in one of the plugins. Add them back one at a time, reloading and checking your page, until the error happens again – then you know the source of your problem. If the error does not go away after disabling the plugins – let me know, we’ll have to try more troubleshooting steps.

Leave a Reply